Wednesday, 2 July 2014

Stadium 4.1.2557.5603 is available

Stadium 4.1.2557.5603 is available for download from the Twenty57 website. It contains the following features and fixes. Thank you to Ryan for all the development work.
  • URL Viewer sizes to the content if the height and width properties are left empty (default values)
    • If the width is less than Stadium then it sizes to Stadium's width
    • Specifying the height and width in pixels or percentages will work the same way as before
  •  See what access rights are applied to which pages and controls by exporting a file from the designer
    • Select File>Generate Access Rights Summary
    • A csv file is written to the same folder that the SAP file is saved too
  • Image Viewer Zoom to Fit option. The image will be automatically resized to fit the container without scroll bars
    • Property on the control with a Default Value of True
    • Button on the Image Viewer for the User to remove all zoom and fit the image to the container
  • Warn the user that not all functionality may work as expected if they are accessing Stadium from a browser other than Internet Explorer
  • OR join option for the Specify Conditions Operator
    • The first condition must be AND. If you delete the first condition and the second condition is OR, it will automatically be made AND
    • AND is evaluated before OR so C1 OR C2 AND C3 will be C1 OR (C2 AND C3)
  • Copy between SAP file is working again
    • Both SAP Files need to be open. Right Click the page you want to copy and drag it onto the Pages node of the second sap file. Release the mouse and Select 'Copy'
  • Validations linked to a stand alone button are now working in a User Control
We are going to investigate the possibility of upgrading Stadium 4 to .net Framework 4.5. This will allow us to make use of newer versions of the ASP.net controls which may make other browser support more feasible. No guarantees at this stage though! It does mean we will potentially need to drop support for IE 7 and 8. Please let me know what version of IE your clients are using with Stadium 4 if you haven't yet done so. Any changes to supported operating systems and browsers will be communicated in advance, not just when the build is released and we'll only make the leap if there are enough clients who can make the jump/require the upgrade. If you have any concerns please let me know.

No comments:

Post a comment